Mendeley

Mendeley Desktop won't work with Qt 4.8

Sandro Andrade Dec 21, 2011 12:01AM GMT

Hi, when running Mendeley Desktop with Qt 4.8 I get a "QSharedPointer: pointer 0x2663090 already has reference counting" message.

strace output:
http://paste.kde.org/176066/

Up 6 Rated Down
Charlotte Dec 21, 2011 10:13AM GMT Mendeley Agent

Could you please try try running Mendeley Desktop 1.3 with the —force-bundled-qt command-line option, and see if this helps?

Up 1 Rated Down
Robert Knight Dec 21, 2011 10:51PM GMT

This issue affects Fedora 16 which was shipping pre-releases of Qt 4.8 until recently.

The problem can be worked around by running:

mendeleydesktop --force-bundled-qt

From a terminal, using Mendeley Desktop 1.3.

Up 1 Rated Down
Dominique Chariot Dec 22, 2011 11:57AM GMT

This issue also affects me on Arch Linux. My Qt version is indeed 4.8.

The proposed solution does not work for me, I receive the following error:
"error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory"

My version of libpng is 1.4.8.

Up 0 Rated Down
Charlotte Dec 22, 2011 12:11PM GMT Mendeley Agent

Could you please try the suggestions at http://feedback.mendeley.com/forums/4941-mendeley-feedback/suggestions/471527-libpng-1-4?ref=title and see if they help? Thanks in advance.

Up 0 Rated Down
Robert Schittny Jan 03, 2012 09:27AM GMT

Doesn't work for me either (Arch Linux with QT 4.8). libpng is 1.4.8, thus symlinking the libpng doesn't work.

A fix would be highly appreciated!

Up 1 Rated Down
Alexander Minges Jan 03, 2012 03:39PM GMT

As a temporary solution you can install libpng12 on Arch Linux from the AUR (http://aur.archlinux.org). Afterwards the --force-bundled-qt switch worked for me.

Up 0 Rated Down
Vincent Leroy Jan 18, 2012 12:37PM GMT

Hi, I have the same issue on MacOS X Snow Leopard. The --force-bundled-qt hint does not work for me.

QSharedPointer: pointer 0x217a7650 already has reference counting

Up 0 Rated Down
Nicolau Werneck Jan 20, 2012 06:00PM GMT

--force-bundled-qt worked for me, Arch Linux with Qt 4.8, no libpng problems (1.4.8-1 installed)

Up 0 Rated Down
Jon Leighton Jan 24, 2012 01:13AM GMT

I'm stuck too, running Fedora 16, the --force-bundled-qt fix does not work.

Up 0 Rated Down
Bogdan Șerban Jan 24, 2012 08:39PM GMT

Same error here. After running mendeleydesktop --force-bundled-qt I get:

Forcing bundled Qt
Running /opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486 --force-bundled-qt
/opt/mendeleydesktop/bin/..//lib/mendeleydesktop/libexec/mendeleydesktop.i486: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Up 0 Rated Down
Robert Knight Mar 06, 2012 10:21AM GMT

The incompatibility with certain builds of Qt 4.8 is fixed in MD 1.5-dev2: http://www.mendeley.com/download-mendeley-desktop/preview/

Up 0 Rated Down
Chris George Apr 13, 2012 11:15PM BST

Installed on Arch Linux 64bit, same problem. Installed preview version and it works flawlessly. Thank-you.

This question is closed to new answers.

Contact Us