Mendeley

Detecting Duplicates

You can detect duplicates in Mendeley Desktop by opening the program and clicking Tools >Check for Duplicates. Please see the video below for more details.



 

Checking for duplicates

  1. Select any folder or group you would like to check for duplicates (eg: All Documents).
  2. Select the "Tools" menu, and select the "Check for Duplicates" option.
  3. Sets of duplicates will then be shown. Think of a set as what the result of your merge will look like when you confirm it. You can double click a set to expand it and view each duplicate document individually.
 

Merging duplicates

  1. Select a set and review the metadata in the right hand details pane. Any field which has a tick to the left of it has no conflicts, which means a merge will result in no data being lost. If there are no conflicts, you can click the "Confirm Merge" button to merge the set.
  2. If a field is un-checked, that means 2 or more duplicates in the set have conflicting data. Mendeley has tried to choose the "best value" to make merges as easy as possible, but it pays to run an eye over unchecked fields quickly as a habit.
  3. If any un-checked field looks incorrect, you can edit the field as you would normally, to input the correct data.
  4. Alternatively, if you know that one of your duplicates had the correct metadata, but Mendeley has picked the wrong data for some reason, you can expand the set by double clicking (or clicking the expand arrow to the left), select the correct document, and tick the box next to the metadata you want to use. You can pick and choose data individually this way from any documents in the set, but be aware that when you check a box here, it will overwrite what was previously selected as the correct data for the merge.
 

Incorrect duplicates

If you notice 2 documents have been put in a duplicate set, but are not duplicates, simply expand the set, select any document that's incorrectly marked as a duplicate, and click the "Not a Duplicate" button in the area above the details pane. This is often required if you have many items with "No Title".

Please note: The 'Not a Duplicate' decision is currently temporary, if you re-run the 'Check for Duplicates' tool again later these documents will still be shown as duplicates.

 

Manually merging duplicates

If you notice that you have duplicates that the tool isn't finding for some reason, no matter! You can merge any documents you like manually. Simply select 2 or more documents while holding down the CTRL key (or CMD key for Mac users) and you'll see that a "Merge Documents" button appears on the right hand pane. Click this and then follow the regular steps above.

 

Oops, I made a mistake!

With great power comes great responsibility. Any merge you do in the de-duplication tool can be undone using the standard Edit > Undo. If you only realize quite a bit later that you've made a mistake, don't worry. When duplicates are merged, all old documents are put into the Trash, and a new document is created from the merge process, so assuming you haven't cleared your Trash, you can restore the original documents from there, and attempt the merge again.

Contact Us